Username:    Password:    Remember Me?         

Lag with new laptop - Reverie World Studios Forums

Go Back   Reverie World Studios Forums > Kingdom Wars > Technical Support
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 06-19-2013, 04:01 PM
Ryondo Ryondo is offline
Junior Member
 
Join Date: Jun 2013
Posts: 3
Ryondo has a default reputation
Default Lag with new laptop

Hey, I just got this laptop about 4 months ago and it's a modern machine. here is a link to newegg with the exact specs.

http://www.newegg.com/Product/Produc...82E16834152363

Can anyone give me a quick run through of some things that might be the issue with why this game is lagging so bad. The lag is in the main menu and in game. It is about 5fps so It's unplayable. Thanks for the help.
Reply With Quote
  #2  
Old 06-19-2013, 04:41 PM
miklos1 miklos1 is offline
DoF Moderator
 
Join Date: Jan 2011
Location: Ga
Posts: 232
miklos1 is just above average reputation
Default

what operating system you using i had problems with lag off of windows 7 for some weird reason.
all hows your internet? and where do you get the lag? in pvp in world map?
Reply With Quote
  #3  
Old 06-19-2013, 04:45 PM
Ryondo Ryondo is offline
Junior Member
 
Join Date: Jun 2013
Posts: 3
Ryondo has a default reputation
Default

I have windows 8. My internet is fine. I get the lag in the main screen with the castle under siege and when i try and do the tutorial. I haven't even ventured into the actual game yet.
Reply With Quote
  #4  
Old 06-19-2013, 05:00 PM
miklos1 miklos1 is offline
DoF Moderator
 
Join Date: Jan 2011
Location: Ga
Posts: 232
miklos1 is just above average reputation
Default

thats weird make sure your firewall is allowing the game try turning down options down.
Reply With Quote
  #5  
Old 06-19-2013, 05:36 PM
Ryondo Ryondo is offline
Junior Member
 
Join Date: Jun 2013
Posts: 3
Ryondo has a default reputation
Default

When i turn down the options it does cut the lag way down, but I really shouldn't have too. Maybe there is a setting somewhere that could be the source of the problem?

EDIT

I just turned down all the settings and the tutorial is still pretty laggy.

Last edited by Ryondo : 06-19-2013 at 05:51 PM.
Reply With Quote
  #6  
Old 06-19-2013, 07:59 PM
Konstantin Fomenko's Avatar
Konstantin Fomenko Konstantin Fomenko is offline
Reverie World Studios - Producer & Design Director
 
Join Date: Mar 2007
Posts: 4,787
Konstantin Fomenko has extremely good reputationKonstantin Fomenko has extremely good reputationKonstantin Fomenko has extremely good reputationKonstantin Fomenko has extremely good reputation
Default

Hello,

I replied in the other post on Steam. You should try updating windows - full update of all drivers, and mainly update your video card drivers.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump


All times are GMT -6. The time now is 06:02 PM.

ESRB Rated T
US/CANADA
PEGI 16
EUROPE
USK 16
GERMANY

privacy policy   |   Copyright © Reverie World Studios INC.

Kingdom Wars and Reverie World Studios are trademarks of Reverie World Studios, Inc. Developed by Reverie World Studios, inc. All Rights Reserved. All other trademarks are property of their respective owners.
Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.