Username:    Password:    Remember Me?         

Low performance/Fast comp - Reverie World Studios Forums

Go Back   Reverie World Studios Forums > Dawn of Fantasy > Technical Support
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 10-05-2011, 12:49 PM
fartsicle fartsicle is offline
Junior Member
 
Join Date: Oct 2011
Posts: 4
fartsicle has a default reputation
Default Low performance/Fast comp

Hi guys, just bought the game today, and I seem to be suffering horrid performance on a fast gaming computer. Very dissapointing since obviously, the game isn't a graphical powerhouse.

Win 7 64Bit
AMD Hexacore processor @4Ghz each core constant
16Gig Dominator Ram
Radeon 5870 2GB GPU
SB Fatality Gamer sound card
Game is installed on a SSD drive

The game has massive slowdown when scrolling, and sometimes crashes with a BSOD when the action is heated. This is unfortunate, I understand not all games are the same, but note I have zero crashes in any other modern games I play and am able to play at the highest settings with 60-200 FPS. (for what its worth)

My hardware is not overheating, as the temperture is low on my GPU, and my CPU is watercooled, and doesnt overheat whatsoever or crash on any other program I play.

My drivers, are all completely up to date. I'm not running any programs in the backround that might slow down the game either, the HD is very clean, and well maintained.

Please help
Reply With Quote
  #2  
Old 10-05-2011, 01:47 PM
Hellsink Hellsink is offline
Junior Member
 
Join Date: Oct 2011
Posts: 3
Hellsink has a default reputation
Default

This sounds bad, I was thinking that performance problems that I have experienced with the game were due to my aged computer setup, but when I look at your specs it makes me wonder how much of the game's low performance can be actually contributed to coding?

Could it be an ATI - related problem? I have Radeon 5850 and the game should not stutter and lag as much as it does now.

"View" - mode is unplayable for me at the moment with constant multi-second lags.
Reply With Quote
  #3  
Old 10-05-2011, 03:37 PM
Jean=A=Luc's Avatar
Jean=A=Luc Jean=A=Luc is offline
Reverie Moderator
 
Join Date: Jan 2008
Posts: 636
Jean=A=Luc has a spectacular aura aboutJean=A=Luc has a spectacular aura about
Default

Quote:
Originally Posted by Hellsink View Post
"View" - mode is unplayable for me at the moment with constant multi-second lags.
Same for me and it also goes for PvP, simply unplayable amounts of stuttering and lag. Hometown runs pretty smoothly though with only occasional hiccups.

My PC isn't as good as the OP's but it's good enough to run Space Marine smoothly, for example.
__________________
The first duty of every Starfleet officer is to the truth, whether it's scientific truth or historical truth or personal truth! It is the guiding principle on which Starfleet is based! *Jean-Luc Picard*
Reply With Quote
  #4  
Old 10-05-2011, 04:05 PM
evansgreen evansgreen is offline
Junior Member
 
Join Date: Oct 2011
Posts: 15
evansgreen has a default reputation
Default

"I have massive slowdown when scrolling"

That's the problem mate. Your comp is fine. The code is "fine". I quote it cause actually is horrid and full of bugs but it's not a poor graphic implementation what is causing your problem.

I had the exact same problem with a very good computer. Tried EVERYTHING, and it didn't work. In the end I just bought a crappy mouse and the scrolling slowdown just dissapeared and everything works fine. If you're desperate to play like me, try plugin in a crapmouse that you have around.

In case anyone wonders, I don't post in the cursor bug/lag the solving of my problem cause is NOT solved. I had to spend money and buy another mouse, and the fault was not my mouse cause we're a legion with this bug, only some of us didn't manage to identify the cause and we relate it to graphics coding or another things. It took me some time to realise that it was scrolling, and certain way of doing it, what caused the bug.

Please developers, make your best to make the game compatible with mouses or drivers or whatever it is that makes it so impossible to play! I've been asking on the chat and there are a few persons other than me that are experimenting it!
Reply With Quote
  #5  
Old 10-05-2011, 05:54 PM
Psych Psych is offline
Junior Member
 
Join Date: Oct 2011
Posts: 29
Psych has a default reputation
Default

I reported this problem a few days ago, they are still working on optimizing the code, but there's lots of other issues they have to prioritize too I'm sure, PVP crashing due to network problems, which has been wayyyy better since v1.04, and then just complete crashes in general. Anyways it's probably not ATI or nVidia. I have 2 computers identicle other then the video cards, one has a nVidia GTX580 the other has an ATI 5780 (I think I forgot exactly but it doesn't matter here because) they both lag in view mode, bad... I get the stuttering, the 30 seconds of complete freezing, and then it moves again. It appeared more like a cpu/optimization issue to me, but I'm hardware/network guy more, so the devs will have a much better idea then me =) All I know about coding is there isn't a wall thick enough for how many times you bang yer head against it while trying to get things to work properly.

edit: forgot to mention I'm running Intel core i7-920's on those rigs.
Reply With Quote
  #6  
Old 10-05-2011, 06:00 PM
fartsicle fartsicle is offline
Junior Member
 
Join Date: Oct 2011
Posts: 4
fartsicle has a default reputation
Default

Quote:
Originally Posted by evansgreen View Post
"I have massive slowdown when scrolling"

That's the problem mate. Your comp is fine. The code is "fine". I quote it cause actually is horrid and full of bugs but it's not a poor graphic implementation what is causing your problem.

I had the exact same problem with a very good computer. Tried EVERYTHING, and it didn't work. In the end I just bought a crappy mouse and the scrolling slowdown just dissapeared and everything works fine. If you're desperate to play like me, try plugin in a crapmouse that you have around.

In case anyone wonders, I don't post in the cursor bug/lag the solving of my problem cause is NOT solved. I had to spend money and buy another mouse, and the fault was not my mouse cause we're a legion with this bug, only some of us didn't manage to identify the cause and we relate it to graphics coding or another things. It took me some time to realise that it was scrolling, and certain way of doing it, what caused the bug.

Please developers, make your best to make the game compatible with mouses or drivers or whatever it is that makes it so impossible to play! I've been asking on the chat and there are a few persons other than me that are experimenting it!
I currently use a Razer Naga mouse. I disabled hardware acceleration for the mouse, and this seems to help somewhat. Ill have to try a crap mouse, hopefully they can fix this. It cant be that difficult, compared to crashes to fix, can it?
Reply With Quote
  #7  
Old 10-06-2011, 11:18 AM
xeovy xeovy is offline
Human Sect:
Knight
 
Join Date: Aug 2011
Location: Espaņa
Posts: 151
xeovy has a default reputation
Default

I play in 1680x1050 resolution
Grass, fog, blood, corpses, light points, active, (Disabling these options not work on my pc).
Also with shadows.
everything else at max.
I will play good fps.
Only slows down sometimes when I have many units you selected
when loose, go well.
once or twice slows down a pair of seconds in pvp.
the rest of the time well in pvp
I think those slow down of pvp are lag.No has to do with my graphics.
My pc is this:
Ati Radeon 4870 1GB
Intel Duo E8500 3.16 Mhz
4GB Memory
windows vista 32
the game fps is fine for me, almost all the time.
also use anti-aliasing, anisotropic filtering.
catalyst control center that activated in the game.
__________________
if the battle is very hard
more pleasurable is the victory

Last edited by xeovy : 10-06-2011 at 01:01 PM.
Reply With Quote
  #8  
Old 10-06-2011, 03:13 PM
Irish_PXzyan Irish_PXzyan is offline
Member
 
Join Date: Feb 2007
Posts: 30
Irish_PXzyan has a default reputation
Default

My computer also has issues with performance! Unreal!

I own an Asus Geforce GTX560 Ti Top card and even this can struggle!?!?!

Anyway, In the nvidia control panel, I changed the texture quality from High Quality to Quality and the GPU temp went from on average of 80-85c to 60-63c which is great! Also a decent performance boost in most areas.

I also noticed having very high graphical settings in game can cause lag!! So be sure to keep everything set to just high!
Reply With Quote
  #9  
Old 10-07-2011, 01:53 AM
Hellsink Hellsink is offline
Junior Member
 
Join Date: Oct 2011
Posts: 3
Hellsink has a default reputation
Default

Quote:
Originally Posted by Irish_PXzyan View Post
My computer also has issues with performance! Unreal!
I also noticed having very high graphical settings in game can cause lag!! So be sure to keep everything set to just high!
Do some of the settings actually work? Seems that resolution change, shadows off, weather effects off, etc. don't...
Reply With Quote
  #10  
Old 10-07-2011, 02:06 AM
Eightball Eightball is offline
Junior Member
 
Join Date: Oct 2011
Posts: 20
Eightball has a default reputation
Default

Performance issues here also. Particularly when I select a large group of units and give them a command - this is probably related to CPU btw and NOT to GPU, I reckon the same is for most of the problems. However, my CPU is an intel i7 930, my GPU is a GTX 480, so it seems no matter how powerful your hardware, issues will persist. I can run Battlefield BC 2 and Metro 2033 on MAX SETTINGS and IN STEREOSCOPIC 3D (twice the power needed to do this), yet this game, with its HORRIBLE pixxelated shadows (pixxelated to all hell, i'm pretty sure all they are is giant pixels) can't even run right, its a joke =/ This game has a lot of promise, but the more I try to play it, the more angry I get with it.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump


All times are GMT -6. The time now is 05:36 AM.

ESRB Rated T
US/CANADA
PEGI 16
EUROPE
USK 16
GERMANY

privacy policy   |   Copyright © Reverie World Studios INC.

Dawn of Fantasy and Reverie World Studios are trademarks of Reverie World Studios, Inc. Developed by Reverie World Studios, inc. All Rights Reserved. All other trademarks are property of their respective owners.
Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.