Username:    Password:    Remember Me?         

Reverie World Studios Forums - View Single Post - Gameplay Issues - GUI Menus, Abilities, Formations, Building, Economy e.t.c
View Single Post
  #186  
Old 04-25-2013, 06:30 PM
tipper tipper is offline
Junior Member
 
Join Date: Apr 2013
Posts: 1
tipper has a default reputation
Default

Quest progression bug:

A character will be present in my home city with a ? or ! over his head, but clicking on it selects the character as any other character, giving me the menu with heal, stance, etc. but in no way can I talk to them to access the quest. With the original guy who manages my estate it seems to have a random chance to correct itself when I restart the game. Sir Lentoth just appeared on my map recently and I've been given a quest by the first guy to talk to him, but clicking on Sir Lentoth with the bright yellow exclamation mark over his head does nothing but select him, giving the regular unit menu in the bottom left as described before. I can't talk to him to complete the quest, and nothing I do (including restarting and retrying many times) seems to work.
Impact: I can't do any more quests. I'm not strong enough to attack anyone/anything else yet, so the only way I can receive more crowns now is to waste gold. I basically can't research any technologies for lack of crowns.

Blacksmith/possible free technology bug:

Before building the blacksmith, in the town hall menu the options to upgrade to castle and stronghold are grayed out (Needs Blacksmith -> Masonry) like I would expect. With my wooden wall partially finished, I built a blacksmith, which finished before the wall did. After both were finished, I tried to get the blacksmith to research masonry, but it was grayed out (this was the only engineering research option that was). I checked my town hall and the options to upgrade to castle/stronghold were enabled as if I had researched masonry. I haven't researched any technology in any building yet so my guess is that the masonry option being grayed-out means it's already been researched.
Impact: Free technology??

Building plot bug:

Sometimes (I have not been able to discern a pattern) building plots for city buildings (not mills or spike traps) do not display, and so I am unable to build pretty much anything except houses, spike traps, and mills. I've tried combing the map with units in case they only appear within a certain range of my units, but no dice.

Last edited by tipper : 04-25-2013 at 08:34 PM. Reason: correction
Reply With Quote