Username:    Password:    Remember Me?         

Reverie World Studios Forums - View Single Post - Quest Issues - Online Kingdom Quest bugs
View Single Post
Old 10-01-2011, 11:22 PM
giangfreedom giangfreedom is offline
Join Date: Feb 2011
Posts: 40
giangfreedom has a default reputation
Default human quest

human race
quest name: Sir Lenloth- Expunging the canker 1 and 2. I got 2 question mark target on world map i got there hit the enter quest icon.

at the first target i tried twice with 1 and 6

at the 2nd target i tried 1 time at option number 2

note : both target ask me to choose between 1 and 6 enemy troop.

as soon as i get in the battle map a clock pop up and i have 30 min before i get kick out ( usually it only pop up when i finish the battle)

i killed all enemy troop within 10-20 for all 3 fight

Now the question: after i wipe out the enemy nothing happen. I tried to wait until the count down is over after i finish off everything still nothing happen to my quest. So, i figure out maybe it is bugged. Could you be kind enough to check it?