Reverie World Studios Forums

Reverie World Studios Forums (http://www.reverieworld.com/forums/index.php)
-   Bug Reports (http://www.reverieworld.com/forums/forumdisplay.php?f=36)
-   -   Quest Issues - Online Kingdom Quest bugs (http://www.reverieworld.com/forums/showthread.php?t=4105)

Danny Vink 09-28-2011 08:49 PM

Quest Issues - Online Kingdom Quest bugs
 
Report any Online Kingdom quest related issues here

Make sure to include:

Exactly what you were doing when the problem occurred (what you did, where you moved, what you clicked, etc)
Anything else you think might be important.

Jean=A=Luc 09-30-2011 09:09 AM

This is a bit of a weird series of quest related bugs with the Elves of Taltos. Bear with me please. :P
I had made my first elven alpine settlement and played for an hour or two. Eventually I wanted to start building some walls but was confused as to what the difference was between the two types of wooden fortifications (walls & wines) since both cost the same and if their price (or some of it at least) would be refunded once I switched to stone walls (which also have two versions of unknown difference, citadel & haven iirc).

In the end I sort of just clicked to build the wooden walls hoping to get some insight into how it works, looks, what it costs (how large is a "segment") but then I realized just how big of an investment it was and that I had probably wasted both wood and influence early in the game. Unfortunately, unlike with other buildings, wall construction couldn't be cancelled (intended?) so I decided to delete this settlement and start over since I was still very early in the game.

***The important part***
I started a new elven alpine town like before but this time some of the quests would become resolved before I actually completed them. For example I finished the "build elven shrine" quest before I even started building the thing, the same happened with the "breed 5 deer" quest. Finally, after the first human attack, fire arrows suddenly became unlocked for my rangers even though I was nowhere near researching it (didn't even have the required building).

Since then I haven't been able to log back in (reported in another thread) to see what's happened (if I still have fire arrows) but it's as if my account remembered that I had completed some of the quests on the previous playthrough and then auto-completed them the second time around (only the ones mentioned). This doesn't explain the fire arrows though.

Konstantin Fomenko 09-30-2011 10:46 AM

Thanks for the report Jean, yeah looks like this is something we`ll investigate today.

ziogualty 09-30-2011 02:20 PM

Quest: Cleaning house (Humans)
Alpine region.

Talked with Sir Lenthot and recieved units, game crashes short after (i was gathering new and existing units to face orcs). When i back in, the quest is still on, orcs at their place but the alberdiers and archers units recieved from Sir Lenthot are gone.
All i remember is that my archers was guarding a stone mine, close to the orcs spawn, and some light fights are going on involving some orc infantry, my archers and some paesant at work in the mine.

Can u help somehow?

Updated 1:
I managed to kill orcs anyway.
But it would be better if the crash does not steal my units.

Updated 2:
The nice thing after all is how the game sandbox help me to solve the matter. I waited to fight the paesant revolt, gather some money through market, and went to close city to buy mercs.
So if a quest bug deny my reinforcements, i can always get them by myself and crush the paesants anyway.

macamus 09-30-2011 03:36 PM

Broken elf quests
 
Bornthas - Quelling the unrest


Platos - Strike befor stricken part 1 & 2


In theese quests I am allowed to choose the enemy army size rating from 1-6 I tried 5 and 6 on all 3 of theese quests. I spawn in a swamplike map and the enemy army on the other side. After I kill every single one of them nothing happens at all. No victory tick or anything

Jean=A=Luc 09-30-2011 04:09 PM

I merged all the quest related bug reports with this thread. Just a heads up. ;)

macamus 09-30-2011 11:58 PM

Nothras - Defending your homeland

I got both sections of stone walls up in my Elven forest city, yet the quest is not updated :/

xeovy 10-01-2011 09:14 AM

No one attacks my city.
All constructed walls, the city is great.
I have the mission to defend the city.
But do not attack.
It is a problem, my soldiers are bored.
are drunk all day.;)

jinksaw 10-01-2011 01:56 PM

Elf - quest:trail of blood
 
My rangers dont attack enemy. when changing formations they get stuck in green smoke. Have waited 5 min still covered in green smoke. Tried to switch back formations. Still in green smoke and cant be moved. Cant make the quest without my rangers

GPS51 10-01-2011 04:43 PM

GV1.01 Quest "War upon the ancient Enemy" After I greet the city guard at Geelrim I go to Ber'Tanos but he has no ! over his head and there's no green X on the map to mark him and I can't get him to trigger the dialogue. Also both of the "Movement of great discord 1/2" quests don't trigger wins. I enter the quest and it asks what size army I want to face. Upon beating the army size I choose it doesn't trigger the successful quest.


All times are GMT -6. The time now is 04:05 AM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2001-2011 Reverie World Studios INC. All Rights Reserved.