PDA

View Full Version : [BUG] Co-Op UI lock up


Langor
01-29-2014, 03:37 AM
Summary: During Co-Op siege the game's user interface (UI) will become unresponsive where you can only select units but not issue commands. Additionally, the left-click hold box square to select multiple units will get stuck in the screen. Possible trigger: Dragon abilities specifically the Royal Dragon.

Repeatable: Yes (Confirmed multiple instances with 3-5 individual players)

Steps: Create an army with a mix of dragons (for testing purposes). During the siege repeatedly or randomly try to use dragon cast abilities such as fireball or firewall. Eventually you will lose your ability to cast spells or move the unit. You will be able to select any other unit through the UI icons in the upper left only. They also will not be able to cast abilities or move. Also, when you try and multi select units the square box will be stuck in the screen. You will be able to redraw this selection box in different sizes on the screen yet it will not let you select any units. If you try and change your view with center mouse button inside this box nothing will happen. If you try and change your view outside this box it will let you. The UI bug will reset when the co-op siege is complete and you go back to the world map.

Additional information: One report said he had the same bug with an army in the world map by trying to hold down the right mouse button to multi select units. Please see attached photo for example of bug in co-op siege.

http://i.imgur.com/LjWmyIr.jpg

Konstantin Fomenko
01-29-2014, 11:49 AM
AWESOME THANK YOU!

Too bad no lags, but we can reproduce.

vicious666
02-11-2014, 02:11 PM
Tryed for over 1h with 2 computer with 14 dragons and 9 cannons spamming fireball,fly, firewall, area shoot, tryng to stop them while cast and many other things, didnt manage to reproduce it.

if you get always the bug or you know exactly how to reproduce it plz upload the file somewhere and send the link of the logfile to konstantin or me thue pm

ReCoder
02-11-2014, 05:52 PM
It's rare, it's only happened to me twice, but Langor is right on how to reproduce it.

DirtMcGirt
02-13-2014, 03:40 AM
Same thing happened to me a few hours ago, I was in a co-op and it happened after I clicked the fireball button on a dragon the game lagged. (It was the last time I was logged in). I went ahead and did the payoff because the enemy archers was hitting my units and I couldn't move them. After the pay off I went to my home city and when I selected a unit there the unit icon on the bottom left wasn't visible so I couldn't "task, lvl, or use skills" of that unit. I havn't logged back in yet so I'm attaching my last 5 logs to help swat this bug.

Also I'm using the web client not steam.

DirtMcGirt
02-13-2014, 03:53 AM
I have some more info I left out. After I clicked the fireball from the dragon the round icon to place the fireball appeared but I was not able to place it (even if I selected another unit by clicking unit icons on the top left or using the number keys to select groups it stayed), and it did not go away tell I hit esc key. I clicked to go back into the game hoping that fixed it. The circle was gone but I was still not able to give commands. I also tried the drag to select and the giant square I was selecting stayed in place on the screen tell I did the pay off.

Konstantin Fomenko
02-13-2014, 09:32 AM
Thanks for the report! This does help, and I can confirm we`ll have this fixed in patch 24 next week.