View Full Version : Game freeze leaving View army

08-20-2013, 08:17 AM
Every time I go to View army, I can last the full 20 minutes before returning to the World Map. But whether I return at the time limit, or manually return before then, the game stops at the loading screen with no progress on the bar. I can still move the mouse around, but it does not load to World Map. From the game sounds I can hear the estate man telling me my workers need jobs, or sometimes units will engage with roaming mobs, so it's like the game is still running but just won't switch back to World Map. I have to Alt+F4 and then end the process from task manager.

So far this has been an awesome game, and I can play most aspects of it, except for returning to the World Map from View. Have had no issues when doing quests or visiting towns and returning to world. Haven't lost anything but time played, and earned levels/looted gold (the whole reason for going into battle)

Running as Administrator.
Validated all Steam files - 100%
Tried changing the Local folder from Read-only - it won't keep the changes. Just reverts back to read-only.

Didn't know which log files to send, so sent all five.

UPDATE: After starting a new city, made an army and went to World Map and View Map. Took my army in, killed a few units, then returned to World Map and everything loaded fine. Apparently the issue is with my original city.

Checked the logs, and it looks like it is hanging on the last line 'requesting city inner'. Any thoughts? Does this mean my account is bugged server side? Or would re-downloading and installing the client again possibly fix?

08-21-2013, 10:52 AM
Most recent update:

Working on quest Dangerous Neighbors. Just finished target 2 in the Wold, working on number 3 in Rolling Plains. In 2 attempts, I've gotten the town hall down to 1 hp (screenshot attached) but not getting any updates for quest completion. The battle just keeps going on. Have to end process and log back in. Still not losing any units, just time.

I'm at a loss here for what to do. Really enjoying the game, but my progress is at a standstill. Attached the most recent Log after force quitting the app.

08-21-2013, 06:29 PM
Deleted local content, installed game again. Still freezes on load screen when returning to World Map.

08-22-2013, 05:02 AM
So I tried using View army again on my second city. No issues returning to the World Map. Compared the logs between the cities:

1st city (bugged) shows line: requesting city inner 0
and then end of file.

2nd city (successful) shows line: requesting city inner 1
then proceeds with loading, logging out to main menu and game exit

Should that line have a 1 instead of 0?

OK so nevermind on that theory. I made two other cities and checked the logs. The third city shows requesting city inner 2, and the fourth city shows requesting inner city 3. Apparently that number is just for which city you are playing (0-3).

My main city is stuck at the request, and not continuing to handle_load_home_city_inner.

08-22-2013, 10:03 AM
alright then contact support or ill have someone look at it..... looks like a bug

08-22-2013, 02:34 PM
Thank you for the logs, we are looking into this as soon as we can, and will let you know how to fix this bug.

08-24-2013, 06:12 AM
Tried some of the simpler suggestions given by the mods in-game, and got my city going. Probably should have tried these sequentially to see which one was the actual fix, but ended up doing them all before trying the game:

Reset modem and router
All drivers were already up to date
Changed firewall rule for dof.exe from Auto to Always Allow

First time I tried the View army and then Proceed to World Map, it loaded right up. :D But then when I logged out and tried to log back in to a different city, I got the "Connection Timed Out" error. So I exited game to restart the client, but the process wouldn't end. I was at desktop, but the game sounds were in a broken loop. Had to manually end it from Task Manager.

Logged back in, and none of my progress had been saved from the previous play. But since then, everything is working fine. So I'll keep my fingers crossed. :p

Thanks everyone for the assists. Here is one last log from the failed game shutdown.