PDA

View Full Version : Out of Sync and PVP artifact


LetoAtreides
04-26-2013, 02:02 AM
I'm Leto and this is my story :p

The reason for posting in this forum:
I have a friend that I specifically signed up to benefit my own agenda aka he builds an army and then I invite him to storm a castle - get a coca cola and let him do the hard work.
So after supporting his startup (kick start project) I send resources he grows quicker .
I invited him for a first ROI battle (the person does not know he's investment)
and we keep getting out of sync messages, battle loads and directly the message pop's up
tried debugging it myself removing specific units from my army, hero trees I saw there was an error loading one of the graphics related to the Dwarf ram, so removed that too - unfortunately nothing seemed to have helped the issue.
When I look in the log1 I see a **** load of resources that are not found, but further than that to my newbie QA face it all seemed relatively ok. Upl

Uploaded the log for review by better educated people.

Other info import to mention I guess, 2 weeks ago when he just came out of his egg; I was able to drag him along to his certain death .
* Tried 2 different cities, same result (including the city that did work before)
* I'm an elf, that should have been a dwarf.
* he's an orc, and perfect for it.
* Attacked city is Human (at a later stage I might be able to make him turn on his own "people"
* My army is relatively the same as it was 2 weeks ago, just a day older a bit wiser (leveled up)
Dragons stayed home

-----------------------
Issue 2, and since the 2 might be related I don't open a new topic.
My elfs have a bit of an 5th dimension love, they like to all stand on the same spot;
Now this would all be great if it wasn't for that I was absolutely not able to play the game for about 2 days - after the patch of Monday (balance 1) I logged on, and everything lagged, stuttered and was otherwise a charm - even the steam overlay did not want to display in less than 4 sec.

So I started up Dead island, Call of duty, F1 13, and basically any other game i could grab to see the performance there - Excellent, no lag no bull**** .
So after 3 days of detox I looked in logs, saw a lot of health is too much (can you ever have too much?) and thought that maybe because of the balancing it was resolving incompatibilities so gave it a bit (10min) nothing ... I started moving units that looked a bit misplaced - this seemed to increase performance. So I sent all the elf's on a forced pilgrim and instantly everything ran smoothly.

Again never had this issue before the path, not sure it's related, but it reminded me of the begin of battle lag if you have a lot of brave souls the game seems to run some sort of Object collision with object X and well keeps doing that as the issue is not resolved till you regroup your army.

--------
Last and least:

This are the steps I need to do to get a battle underway with specif people

1. go to the same city.
2. both call the mayor a simcity mayor.
3. other player goes to siege, type my name
4. get a message: no suitable army's are found
5. I press siege, type name of other commander
6. voila works.

any other way, me invite he invite ends up in a loop
he invites only always ends up in no suitable army (even after 2 battles)

Army's are within the limits.

Ok that's it for me, take care don't make me go back to Simcity, please .....:) *

* It's begging not a threat

Brian Shingles
04-26-2013, 11:35 AM
That's probably one of the most entertaining bug reports I've read :)

Re-validating/Verifying game files (https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335) and ensuring you've both updated can help with Out of Sync issues.

I'll check through your log shortly, too, to see if there are any problems there.

We'll look into the issue of elven units appearing in the same spot and causing lag.

With entering the player name for coop, it is case-sensitive so that could be an issue. We could look at adding a drop-down list with your friends' names, to simplify things.

LetoAtreides
04-26-2013, 05:25 PM
Thanks Brian!

Yes the validation of the steam files we did, no issues detected - at least none that they wanted to share with us.

Indeed DOF case sensitive we found out the hard way
For me I wanted to name my sponsor as referral but typed his name without a capital (then the game told me I had no friends..) but thanks to the kind support he did get his reward and I got my friend back.

And the other friend could not logon, he kept typing his username without a capital - took him hours to figure that one out. Strengthened my case for insanity
"Quote: "Insanity is doing the same thing over and over again but expecting different results."

So cap sensitive should at least with us not be the problem.

Love that there is such an active development going on - so if you need me to test anything let me know.

Reinstall game, try it with another army or units.. I'll do everything short of getting a new friend as I have to work with him everyday