PDA

View Full Version : Invisiable Ogres


nic9185
04-18-2013, 10:46 AM
I have noticed when conducting raids in a "camped" setting that there are invisible ogres attacking my troops. said ogres can be killed but you have to notice where your troops are randomly dieing to kill it. I know its an ogre because it makes those noises when it rapes my marauders.

SadClown
04-18-2013, 12:06 PM
I remember having this bug in one of the orc quests looong time ago.

Konstantin Fomenko
04-18-2013, 03:57 PM
Guys, can you please provide more details - on how exactly we can reproduce this step by step, the more details the better. Was trying to find how to recreate this for a while now.

SadClown
04-18-2013, 05:02 PM
I'm sorry, it was a year ago when I had it. All I remember is ranged units being unable to hit it, melee units being able to, no shadows or further effect from the attacks and ogre bodies dropping off, which were lootable. Thus the bug lasts while it's alive.

I do think it was on the quest when you pass by different orc villages and ambushes happen. I might be messing up though.

SadClown
04-27-2013, 03:11 AM
Found it, and made a video.

http://www.youtube.com/watch?v=h1qxDRPjzPg&feature=youtu.be

Nobodave
04-30-2013, 03:59 AM
For me the steps were ...
0. Buy game via Steam
1. After fiddling with humies and elves, start the Orc campaign in Swamp
2. build a fair number of huts early on, build units, and go raiding a bit to level up units
3. Play the campaign missions until Honor to the Victor shows up
4. Having brought too large an army including siege stuff, enter mission (not taking all units)
Not sure if any of these steps are required.

PC: AMD PhenomII, Radeon HD 5670, Win7

Brian Shingles
04-30-2013, 09:59 AM
That's odd, I've played that quest dozens of times (and again just now) and the Ogres are always visible.

If it's happening elsewhere, that suggests it's possibly due to missing/corrupt Ogre model/animation files. Since I can't replicate the problem you are having, I deleted my Ogre model/animation files and that did indeed make them invisible.

I'd recommend verifying game files (https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335) and seeing if that makes the Ogres visible.

Call4God
04-30-2013, 05:12 PM
it comes and goes. I had the ogres from the orc quests turn invisible after a CTD, tried restart,etc, stayed invisible. After I logged back into my human town then back a week later I culd see em again. Also had it occur randomly in orc lands while viewing map.

Rusmolot
04-30-2013, 09:04 PM
For me the steps were:
1) Start the Orc campaign, forest region.
2) Progress through the quests until you reach ogre party.
3) Accept the quest Ogre Party
4) Crash the game (unknown cause?)
5) Log back in, no ogres visible. (not sure if they're missing entirely or they're invisible.

Rusmolot
05-02-2013, 12:02 AM
Alright so I've logged in and out to no avail, I've run integrity check and that didn't replace anything so I went in
$STEAM/steamapps/common/Dawn Of Fantasy/Art/models/orc/units and deleted
/ogreand just in case, I also deleted
/ogre_worker then ran integrity check again. Steam downloaded 44 files and ogres reappeared. Can anyone verify?

PS. Based on how my ogres disappeared could it be possible that the script that was supposed to spawn the ogres ended up corrupting the model files somehow?

Konstantin Fomenko
05-02-2013, 11:13 AM
Just verified that does seem to be a problem with Steam not downloading some files - Ogres in your case. But this is on top of the other issue we have - with Ogre Party quest sometimes making them go invisible - we`ll keep on looking into this - although we are not treating this as a high priority issue.

corecpu
05-02-2013, 11:15 AM
My ogres vanished aswell, happen during the quest when u supposed to capture your first ogres at diffrent location, I accepted the quest but didnt have time to play more so I logged out, and when I came backin they where invis.

the solution in this thread worked fine.