PDA

View Full Version : Archers not working properly


CrimsonEpitaph
04-13-2013, 11:40 AM
I recently found out that my archers/crossbowman are not working properly. When engaging troops from afar while they are on the circular towers they work just fine. But what I noticed is when the enemy force would enter my town the archers would stop working.

Yes, I did check whether or not they ran out of arrows but they still had plenty left. I then took them down from the towers into ground level but they still wouldn't engage the enemy. Even the enemy which was my buddy, could not get his archers and crossbowman to engage my troops.

jc984
04-13-2013, 11:43 AM
I recently found out that my archers/crossbowman are not working properly. When engaging troops from afar while they are on the circular towers they work just fine. But what I noticed is when the enemy force would enter my town the archers would stop working.

Yes, I did check whether or not they ran out of arrows but they still had plenty left. I then took them down from the towers into ground level but they still wouldn't engage the enemy. Even the enemy which was my buddy, could not get his archers and crossbowman to engage my troops.
Yea none of them worked on the ground after putting them in his towers. Every now and then they will shoot off an arrow. But i know there quivers werent empty cause each squad had over 100 or so left. They even didnt work properly after i went into the field.

My main base is in southmont and i never had this issue before.