PDA

View Full Version : Test Scenario button not launching DoF


KingGsterUK
04-12-2013, 07:50 PM
Introduction
Hey all,

I've been playing around in the editor creating new landscapes and I've got to a point where I'd like to see how it will look in-game. My map is made up of just terrain, elevation and environment adjustments, with player 1 & 2 as hero's placed on the map.

My Problem
I want to see the progress of my current creation in the game engine but when I click on the "Test Scenario" button, the DoF.exe opens and closes again straight away. Nothing happens basically.

Information
All 3 applications run in administrator mode: Steam, DoF and Editor.
Currently myMap lies in the \Resource\myMaps\. (on another topic, the "Resource" folder didn't exist and according to your editor .pdf manual, Found Here (http://www.reverieworld.com/design/DOF%20Scenario%20Design%20Intro.pdf) there's a list of special effects that's supposed to reside in there, which isn't there)

I've also tried moving the map file to:
\Scenario\,
\Scenario\myMaps\,
\Scenario\Tutorial\,
\Scenario\Sample Levels\.

None of which allows me to access the map I have created from any single player menus.

Possible Problems
Does the problem lie in where the map file is saved?
Is there a specific path for launching myMap through the editor and is there a specific path for launching myMap through the actual game?
Could the problem lie with steam? Trying to launch the game and steam cries! "YOU SHALL NOT PASS!!!"
Maybe it's because I don't have any win conditions or camera's set up or whatever? Although, I have loaded up the tutorial levels in the editor and clicked on "Test Scenario" for the same results mentioned above.

Maybe I'm Blind
I can see this being something and nothing. I tried the search function with a few strings but couldn't find anything relevant.

Cheers.

GPS51
04-12-2013, 08:09 PM
I'm guessing, guessing mind you that because the editor was created before the steam release that it's conflicting with it.

Edit: When I tried that with my non steam version of dof the editor loaded into dof just fine. Hopefully the devs can find a quick fix to allow it to work within steam.

Brian Shingles
04-13-2013, 06:12 AM
The Editor is not fully enabled in the Steam release at the moment, so it's nothing you are doing wrong.

When we get a chance, we will look at enabling it fully with possible Steam Workshop integration for sharing custom scenarios.

We'll also look at adding the Load Scenario option back into the Singleplayer menu, which would probably be the easiest option for us to do.

The Resources folder exists as Resources.mithpak, which secures it against inadvertent changes that might compromise game file.

As GPS51 said, the Editor with the non-Steam version works for testing scenarios, so if you cannot wait until we have time to update, then you can install this with your existing game key.