PDA

View Full Version : Client loads then crashes when hit play


jmedics
04-12-2013, 03:36 PM
When I open DoF then client loads fine. Everything validates fine, but when I hit play the screen goes black then it says DOF.exe has stopped working. Tried uninstall/reinstall and still the same issue. Anyone else have same issue and have a fix?

Game worked fine last night and this morning now it is suddenly doing this.

Zvonzi
04-12-2013, 03:40 PM
Did you update game after last night patch?

I'm not tech support, but maybe try some of solutions here - http://www.reverieworld.com/forums/showpost.php?p=78133&postcount=6 and http://www.reverieworld.com/forums/showpost.php?p=78146&postcount=3

Also, feel free to post log.txt file located in game folder.

jmedics
04-12-2013, 03:47 PM
I tried both fixes you posted and nothing. As I stated I have been playing this morning and last night (version 1.5.1).

Zvonzi
04-12-2013, 03:50 PM
I tried both fixes you posted and nothing. As I stated I have been playing this morning and last night (version 1.5.1).

Didn't see that "this morning" part. I'm out of ideas then. :(

It would be best to wait for some DEV or our Tech Support :D

jmedics
04-12-2013, 03:50 PM
Will do thanks for the help!

Zvonzi
04-12-2013, 03:55 PM
Btw, try to re-validate game files thru Steam ;)

jmedics
04-12-2013, 04:00 PM
I don't have the game set up through steam. Just downloaded from here, installed, and started playing like games prior to steam and similar programs.

Zvonzi
04-12-2013, 04:12 PM
Oh, okay then. This was my last idea :D

Jester0311
04-12-2013, 10:48 PM
Looks like your having some audio issues obviously :) Can you post dxdiag so i can get a feel for what im working with? also it may prove more informational on your underlying issue.

Also check your Dawn of Fantasy main directory for ogg.dll
if it exists rename it to ogg.dll.old
move or rename the sound folder that is there as well.
Then im not sure if the client will do a verification or if there is a patcher, or possibly a repair...fixlauncher..etc (common in mmo stand alone clients)
sorry i dont know this as im a steam fella.
worse case scenario, re-install, update (add dof.exe, ogg.dll, mithrill.dll as firewall exceptions prior to update)

jmedics
04-13-2013, 12:00 AM
Well your saying something about sounds made me look at my sound settings. I came to notice that by having my speakers disabled and my headphones not plugged in the game will crash at load. If I have the speakers enabled than the game loads just fine. Odd bug to have found.

Jester0311
04-13-2013, 08:46 PM
Noted, Thanks