PDA

View Full Version : Cannot Register in game


ludivick
04-07-2013, 04:26 AM
Hello!

I bought my copy yesterday and after register sucessufully at Steam I enter the game but find myself unable to register.

I add all details correcly and after I click Create account absolutely nothing happens....

Also the button Back do not work.

Any Idea how can I fix this? The singleplayer seems to work normally

HektikPaule
04-07-2013, 11:07 AM
Same too... Cant create a account... bought at steam...

chicken
04-07-2013, 04:04 PM
I bought this game from steam as well and they gave me a game key that did not work tried many times. and now I can't register this should be fixed asap. I can't go online now becouse i can't register. right now I payed for something i can't use.

ZvonimirG
04-07-2013, 04:42 PM
Hmmm, do you get some kind of error, guys? Have you tried to use different details when choosing your name and stuff like that?

DiscoPickles
04-07-2013, 05:40 PM
I also bought my game just today and can't seem to register. It states "Registering username..." for a few seconds and then "Connection timed out!"

Kingprok
04-07-2013, 05:42 PM
server is down should be up in the next hour

Manusje
04-07-2013, 05:43 PM
Also bought the game on steam round 12:00 AM GM+1 time.

I cannot register in game, When i filled all the register forms it says ''Registering'' and then ''Name is registered''. But then again, nothing is happening and cant log in with that registration i made.

Please help me.

Manusje
04-07-2013, 05:43 PM
server is down should be up in the next hour

Thnx for the information, cheers.