PDA

View Full Version : Game wont save


Infekted
04-02-2013, 03:53 AM
I have restarted an Online Kingdoms game about 4 or 5 times now. It does not matter what I do, or how I exit. When I go back in all progress has been reset.
Is there a hidden "save" button somewhere I'm missing?

Brian Shingles
04-02-2013, 08:53 AM
There is no save button as progress should be saved automatically.

There seems to be some issue which affects a handful of people where the game won't save, however, we've been having trouble replicating and fixing the issue although we have investigated a number of possible solutions.

Any extra information you could provide us would be helpful, such as a dxdiag (http://windows.microsoft.com/en-GB/windows-vista/run-directx-diagnostic-tool) to provide information about your system, what router you use, what time you play and maybe logs from successive game sessions where progress hasn't saved (i.e. play for bit, save log as log1old.txt, play again, if progress hasn't saved then save log as log1new.txt and posting both)

Information on attaching logs can be found here (http://www.reverieworld.com/forums/showthread.php?t=4337)

In the meantime, if you still experience this problem we recommend logging out (which should make it save) after about 10 mins then logging back in again, and if progress has saved you should be able to play for longer

Infekted
04-02-2013, 10:43 AM
Thanks for the response. Ok to clarify. I've actually had a few problems, the not saving being one of them.

As I said I have started multiple times, so far with both Men and Orcs. I played last night for about 4-6 hours? Ish. Maybe less. And then another similar stint on it this afternoon (I am in UK time). It does not matter how I exit the game, be that log out, exit game, or crash out (has happened a few times). Every time I leave the game, all progress is reset and I have to start again from scratch.

I have a couple of other problems, possibly related I do not know:

If I click log out of a game. I can not reconnect to my account in online mode until I exit the game and restart. It just times out repeatedly.

Most of the time, when I exit a "mission" type screen to go to the world map screen, the game freezes on the loading screen. Strangely I can hear sounds and I think I can hear things responding to mouse clicks. But all I can see is the loading screen. I then have to alt+f4 or kill via the task manager.
This has happened both of the times I have completed the first "go somewhere on the world map and kill stuff" missions for men and orcs.
It also happens if I try to inspect my army on the world map then exit back out.

I am 99% sure all my drivers are up to date and my computer works fine for all the other games I have installed on it.

I have attached my dxdiag, and 4 of the 5 log files I found. I shall try the making a new log thing later, I'm a bit burnt out from doing the starting quests over and over again...

Oh I have also tried resetting my router and computer a few times.

Kind of gutted as I'm loving the concept of the game ><

Brian Shingles
04-02-2013, 11:23 AM
Thanks for getting back to us with that information.

It is useful and will help us fix this.

EarthquakeJake
04-03-2013, 05:34 AM
I am having the same problem. But with me I don't even have to leave the map for it to happen.

It happened twice so far and the only thing that they had in common was that they were both men and that it happened when I exited the game. Once by just exiting the game and the other by the game freezing when leaving another castle (another problem).

I really like this game so far so I'm not going to give up on it, just please fix it fast. Its hard watching my roommate play w/o this problem.

Infekted
04-03-2013, 02:23 PM
Tried again after the mini patch today. Elves this time. Still not saving

Konstantin Fomenko
04-03-2013, 02:46 PM
Infekted - does it at least tells you lost connection to server and kicks you to the main menu? Or can you play ok - just that absolutely nothing is being saved?

EarthquakeJake
04-03-2013, 08:41 PM
It doesn't say anything to me, just when i log off for the night.

bandor
04-03-2013, 08:49 PM
I lost about 30-45 minutes today due to not saving

game crashed, got a runtime error, I closed the process from task manager

logged in and found a rollback of my town