View Full Version : Army disapeared

03-07-2013, 10:05 PM
I prepared for the next patch soon to come by creation of an army from my homeland to reduce army points in homeland to compensate for increase of army points for heroes. The new army was made of two dragons, one red dragon and a green one on level 15 and 13 if i remember right. After Army creation I finished for this day and logged out.

Today in the morning I started again playing and noticed that my army No.8 is gone. I checkec if the missing units are in the homeland due to not saving properly and missing the last action but the green and red one are not in the homeland anymore.

The dragons disappeared obviously. I believe there is still a problem with saving properly last action.

Would be nice if you could have a look into it.

It saving happened today very early morning around 01:00 am Abu Dhabi time (GMT+4).

Account: wasserali
Human town in Southmont, 3rd slot
Army no 8 dissapeared which was created from homeland

Log1.txt is attached


Konstantin Fomenko
03-08-2013, 02:09 PM
Thanks for the details report. And please check your private messages inbox for compensation.

Couple of questions:

-How did you log out? Did you went to main menu and click Log Out, or you clicked Exit Game? Or did you use Alt+f4
-Did you by any chance terminate your internet connection or restarted/shut down PC - as soon as you were out of the game?
-How much time passed since creating the army and exiting the game?

03-08-2013, 02:48 PM
Thank you for compensation.
I logged out by exit game.
I shut down computer approx 5 min after ending game. Internet connection should be stable where I played yesterday and today.
Time since creating army and exiting approx. 2 minutes.

Hope this info helps.

I face at the moment an even bigger glitch. First time I started after update 1.4.3 I experienced Multiplication of units in my hometown after approx 2 minutes of play. The screen went black except the town names and other text boxes. Then all my units in hometown where multipied by 2. I tried to resolve with discarding of units but before I could discard it added another set of units (same no of units as initially in hometown). I was in the middle of discarding screen when second incident happend and game did not respond anymore. I left with Alt+F4.

Started game again. Same glich happened before I was able to empty my hometown. I left before it happened again by exit game.

Started again and noticed that the units I removed from hometown after 2nd start of game disappeared. Glitch happend, PaniK! Happend again! Alt+F4!

It appeares to me that I am not able to play with my human town anymore. I hope you can have a look at this.

account name: wasserali
Town name: Hightower, human town in Southmont, slot 3
Log.txt is attached

Original town Army:
Royal Dragon lev 60 (the one I have since october 2011 and you brought back 3 times until now!)
Haunter Dragon lev 25
Ice Dragon lev 14
2 High knights lev 32
3 Protectors lev 22
1 Dragon slayer lev 24
12 squads knights lev 20
20 squads Dwarven riflemen lev 8
1 chart
4 or 6 dwarven miners

I dont know what is left now in my hometown. Some units have been missed others have multiplied. It happens faster than I can rectify and most propably continues till the world is flooded with my armies.

I hope you can fix my town for me. It would be devestating to loose it.


Konstantin Fomenko
03-08-2013, 03:18 PM
Sounds really bad - but I can`t seem to reproduce this. And we never had a report like that. I copied your town - and can play with it just fine - waited 5 minutes and did all sort of stuff.

Your log does show some errors - that I can`t reproduce, but we`ll try to fix them just in case. Once we patch tomorrow you might want to try again.

03-08-2013, 09:15 PM
Thank you for your fast reply and I hope you can do something about it.

With regards to my answers to the firt place I have to add that I encountered several times in the past difficulties to connect to PvP. I answered the call to battle with yes and waited approx. 5 to 10 min at a loading screen until I decided to Alt+F4. it happened several times with Zeikon and also with another guy. Since then I normaly played with attac protection not to disappoint other players and me for waiting in front of the loading screen.

During the week I am currently located in the country side except Thursday evening and Friday where I live in the city. The incidents of waiting in front of the loading screen happened when I was in the country side.

However, while the incident with loosing army and multiplying units in homeland occured the connection should have been stable as it is my private 16 Mb/s connection via cable from aprofessional provider in a well connected country (Abu Dhabi, capital of UAE).



I checked if it still happens. It does! Hometown is missing many units!
I will not play until Thursday since I have no proper connection until then. But I will check on news in the forum. Hopefully there is a solution until coming Thursday.


03-13-2013, 07:54 AM
Having updated with latest patch today I checked my town.

Multiplying still happens!!!!

Checking my units in town before multiplying it seems that i lost now the following units:

Haunter dragon, lvl 25
Ice dragon Lvl 15
5 Squads of dwarfen riflemen level 8 each
4 gangs of dwarfen miners

Still cannot play! please help!


I tried to visit thecouncellor in the town for quest providing Dragon slayer before the multiplication of units start. when reached the councellor and tried to talk the multiplication happend. After that hero was gone. I suspect that the quest providing the dragonslayer is the reason for my problems. This is also because when multiplication started earlier the symbolfor quest at hometown appeared blinking as if a new quest is available.

Please investigate.


03-14-2013, 01:32 PM
I didnt get reply from developers for several days now. It seems that the problems I encounter are not important to them.

Anyhow, I tried to help myself.
- Checked if other towns are affected as well: Yes!
- Deleted game and reinstalled: still duplicating of armies in hometown.
- Tried to finish quest with dragonslayer and dragon: duplicating still happening, dragonslayer dissapeared, Hero once again lost experience.
- Continued playing the game: duplicating happens but after finishing a quest units in hometown are back to normal. All additional unit have dissapeared from hometown. good result! this happened several times and at least I played half an hour without duplicating bug. Resolved? I dont know.

Other issues noticed:

- The units listed in my previous post are now for sure missing. they will not appear without help of developers.
- My level 60 dragon had only 161 skill points instead of 177 as it should be.
- the health bar for many units in the army window of the world view indicated wounded units but in home town they are not wounded
- lvl 20 Knight units with maxed out health in hometown show only 550 health

I hope this will be read by Developers and maybe I will get a reply. Would be nice to know if my efforts to report are noticed or ignored.


Brian Shingles
03-14-2013, 04:25 PM
Sorry for the late reply wasserali. We do appreciate your efforts in reporting things to us.

We'll look into everything you've reported and I'm glad the duplicating issue has been resolved. Odd that completing a quest fixed it, we'll look into that more but we haven't been able to duplicate it so far.

We'll help you sort out the other issues as soon as possible. Kon will have to help you with the missing units though and since he is working with Steam at the moment there might be a delay.

Just on that level 60 dragon issue, there is some old code that was spending 16 skill points on Pierce Resistance, so the points aren't lost, as such, just already spent. We've removed that code now and it will go out with the next patch.

03-15-2013, 01:58 PM
Thank you for reply.

Unfortunately it will take again several days till I am back for checking out any changes or improvements. Thursday/Fraiday I will have time to play and check out if duplicating bug is persistently resolved.


Konstantin Fomenko
03-15-2013, 02:35 PM
Hello Wasserali,

I apologize for not replying earlier, and sorry that you felt ignored - you should know by now, we put our customer support as a first priority - but unfortunately with finalizing the Steam arrangements - we were stretched really thin in the past few days, and I just coundn`t reply - although we did try to reproduce the issues, and fixed some errors that could be related.

Also I noticed you have a large number of crowns in your account, so I took the liberty of sending you the compensation in a more unique format - with unique units you can`t just purchase with Crowns - check your Private Messages for the Codes.

With regard to your bug - we did fix a error we found in your log - in the latest patch 1.4.5 - maybe that`s what stop the multiplying, and you completing the Dragon Invasion quest just happened on the same day?

In any event - please let us know if this happens again, this is a major issue that we must address before the Steam release, but hopefully we already did.

03-18-2013, 09:49 AM
Approx 5 minutes after start of playing the game somehow crashed. I was in the middle of a quest (Wold Stronghold) when the screen went black. Only the unit buttons, return to wordmap button and minimap was visible. rest was black. The minimap was showing the overview of my home town and not the map of the siege. Only way to stop was alt+F4.

This also happened when the duplicating bug happened. Until now the duplicating happend when on the world map or in the home town view. Never while questing. I didnt check no of units in hometown but I am quite sure this is the same bug I described in this thread.

The log file after alt+F4 is attached. I hope this helps to investigate.

I also want to report an observation which might be helpful or might be not: When starting the game or coming back from battle, the loading screen gets black for a second and going back to normal brightness. it happens mostly 2 times, sometimes only one time and once it happened 3 times. This behavior started the same time the duplicating started.

Good luck for the hunt.


Brian Shingles
03-18-2013, 01:18 PM
Thanks for the report and the log.

There are a few new errors in there I've not seen before. I'll work on fixing them and getting that out with the next patch.

04-04-2013, 12:36 PM
After release of latest patches I tested today if the issue of duplicating armies at hometown still happens. It does!

Again I quit game with Alt+F4. Log is attached. I hope you can find the reason for duplicating error and eliminate. Otherwise gameplay is not possible.

Good luck for the hunt.


Brian Shingles
04-04-2013, 01:13 PM
Thanks for the log and for being so patient with us.

We haven't been able to replicate this particular error, even when we've copied your homeland to test.

But we will keep investigating. If we can't find a solution we might try something drastic like giving you a new key to create a new account and copying your cities across.