View Full Version : DoFupdater.exe has stopped working

10-21-2012, 10:22 AM
Hey there, so here's my problem,
I bought this game through Desura in the sale yesterday, it downloaded and installed the client just fine,
I booted it and it asked for my CD key, I entered it and then the splash screen comes up, and the updater tries to load, but just pops up with a blank window and then the typical "this application has stopped working, press this button to close" error window,

btw it no longer asks for my CD key since I entered it first (until I went into AppData and deleted the folder and so it asked for it again of course)

I've installed latest Microsoft Framework, tried running in admin and compatibility mode for XP service pack 2 (I'm running Vista)

I have also tried downloading the client from this website without going through Desura and still the same problem.

I've attached the updater-log file,

any ideas?

Brian Shingles
10-22-2012, 06:46 AM
Here are some steps that have been posted before that might help you. Try running the updater after each step.


Some things you can try.

1) make sure you restart the computer - if you haven`t this could cause that.

2) Disable Anti Virus and Firewall - and if that works set DofUpdater.exe as exception

3) When you start the updater, try to right click - and Start as Administrator (or Run as Administrator)

4) Try installing C runtime libraries. http://www.microsoft.com/en-us/download/details.aspx?id=5555

5) Try getting the latest .Net Framework (free download, just google it)

6) To confirm you already tried using the latest client located here? http://dofgame.com/download/DoFInstaller.exe

7) Lets try uninstall one more time, but this time also removing temp updater files:

a.) Go to your user directory (C:\Users\Your User Name Here) with 'Show Hidden Files and Folders' enabled (see here (http://www.bleepingcomputer.com/tutorials/how-to-see-hidden-files-in-windows/) for details), the folder AppData should appear.
b.) Navigate from your user directory to AppData, and then to Local. For more instruction, see:

Windows 7: http://www.youtube.com/watch?v=UTCXZdOf06Y
Windows XP: http://wiki.answers.com/Q/Application_data_folder_in_windows_xp
Windows Vista: http://techqa.wordpress.com/2008/08/24/appdata-folder-in-windows-vista/

c.) There should be a folder named DoFUpdater there, delete it.

10-22-2012, 10:22 AM
I've already seen that thread and tried everything it has said :/ firewalls off, complete uninstall and removal of temp files in AppData and install, uncheck read-only on all files, install C++ runtime libraries and Microsoft Frameworks, set all executables in the program files to run as admin just incase, latest client and restarted multiple times, still nothing.

Ill try another complete wipe of the install and temp files and reinstall and post the results and updater-log if it still doesn't work

thank you for your time btw

10-23-2012, 06:14 AM
I have done everything that you said, still nothing :/

here is what the updater-log says:


TimeStamp:22/10/2012 13:44:46

Details:System.Reflection.TargetInvocationExceptio n: Exception has been thrown by the target of an invocation. ---> System.ArgumentException: ContentType string is not valid. Expected format is type/subtype.
at MS.Internal.ContentType.ParseTypeAndSubType(String typeAndSubType)
at MS.Internal.ContentType..ctor(String contentType)
at MS.Internal.MimeTypeMapper.GetMimeTypeFromUrlMon(U ri uriSource)
at MS.Internal.MimeTypeMapper.GetMimeTypeFromUri(Uri uriSource)
at MS.Internal.AppModel.ResourcePart.GetContentTypeCo re()
at System.IO.Packaging.PackagePart.get_ContentType()
at MS.Internal.AppModel.ResourcePart.GetStreamCore(Fi leMode mode, FileAccess access)
at System.IO.Packaging.PackagePart.GetStream(FileMode mode, FileAccess access)
at System.IO.Packaging.PackagePart.GetStream()
at System.Windows.Application.GetResourceStream(Uri uriResource)
at DoFUpdater.WPFWindows.winMain.OpenEmbeddedSound(Ur i uri)
at DoFUpdater.WPFWindows.winMain.<DoSounds>b__5(SoundPlayer x, Uri uri)
at DoFUpdater.WPFWindows.winMain.DoSounds()
at DoFUpdater.WPFWindows.winMain..ctor()
at DoFUpdater.WPFWindows.winSplash.ValidKey_Online_Re sponse.<>c__DisplayClassc.<Run>b__b()
--- End of inner exception stack trace ---
at System.RuntimeMethodHandle._InvokeMethodFast(IRunt imeMethodInfo method, Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeType typeOwner)
at System.RuntimeMethodHandle.InvokeMethodFast(IRunti meMethodInfo method, Object target, Object[] arguments, Signature sig, MethodAttributes methodAttributes, RuntimeType typeOwner)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks)
at System.Delegate.DynamicInvokeImpl(Object[] args)
at System.Windows.Threading.ExceptionWrapper.Internal RealCall(Delegate callback, Object args, Int32 numArgs)
at MS.Internal.Threading.ExceptionFilterHelper.TryCat chWhen(Object source, Delegate method, Object args, Int32 numArgs, Delegate catchHandler)

Brian Shingles
10-23-2012, 08:35 AM
I've passed this on to our updater programmer, hopefully he can find a solution for you.

10-25-2012, 07:32 AM
thank you kindly :)

10-28-2012, 03:18 PM
Hello, today while I played my pc froze for not DOF relater issuses and i forced restart.
After fixing the problem, my HDD cable got loose i think..
I tried to play dof again.
So I joined I got back 2 quests but no worries there.
After finishing the first, and begining the second the game crashed again for no reason.
I restarted the Game and played again. This time I was at the same quest, but the second the game loaded Crashed again.
After one more startup of the game After loading to the menu, and before clicking on online kingdoms the game crashed again.

Here are the logs.

Log1-1 After It loaded and I joined online kingdoms and selecting one unit the game crashed

Log1-2 After I tried to click kingom wars in single player the game and Before the game started to Load.