PDA

View Full Version : DOFupdater.exe has stopped working!


Shmevil
09-01-2012, 03:15 PM
Yeah. Read around the forums for a bit... can't find any solution. Windows 7 64bit. I have net installed. It asks for me to insert my CD key, so I do. Then it just tells me it crashes. Ran as admin... crash... any ideas?

Shmevil
09-02-2012, 11:00 AM
Tried reinstalling the game several times, even with a new installer. I get updater updating. Then after a few times it just crashes again after I put in my CDkey. I tried installing the game on a different computer... and it works there, but not on this one. They both have net framework 4 installed, and same with visual c++ runtime. Any ideas?

Shmevil
09-02-2012, 11:38 AM
Don't know if this'll help you guys, but here is a log file... Looks similar to people who had a framework issue... but mine is installed. (re-installed several times as well)

Konstantin Fomenko
09-02-2012, 03:29 PM
Shmevil,

Few more things to try:

1) make sure you restart the computer - if you haven`t this could cause that.

2) Disable Anti Virus and Firewall - and if that works set DofUpdater.exe as exception

3) To confirm you already tried using the latest client located here? http://dofgame.com/download/DoFInstaller.exe

Shmevil
09-02-2012, 03:33 PM
Yeah I have restarted the comuter (Several times after reinstalled net framework), my firewall is currently off. I have tried using that installer.

Konstantin Fomenko
09-02-2012, 03:48 PM
Lets try uninstall one more time, but this time also removing temp updater files.

1.) Go to your user directory (C:\Users\Your User Name Here) with 'Show Hidden Files and Folders' enabled (see here (http://www.bleepingcomputer.com/tutorials/how-to-see-hidden-files-in-windows/) for details), the folder AppData should appear.
2.) Navigate from your user directory to AppData, and then to Local. For more instruction, see:

Windows 7: http://www.youtube.com/watch?v=UTCXZdOf06Y
Windows XP: http://wiki.answers.com/Q/Application_data_folder_in_windows_xp
Windows Vista: http://techqa.wordpress.com/2008/08/24/appdata-folder-in-windows-vista/

3.) There should be a folder named DoFUpdater there, delete it.

Shmevil
09-02-2012, 03:52 PM
already tried that, did it again, still crashes.

Konstantin Fomenko
09-02-2012, 04:10 PM
Ok lets try running it as Admin again, but before that - find where you`ve installed Dawn of Fantasy, right click on the Folder, go to properties, and make sure it`s not Read Only.

Shmevil
09-02-2012, 04:15 PM
It was in my program files, standard install. It was read only, unchecked it. Applied to all files and folders. ran as admin, still crash.

Konstantin Fomenko
09-02-2012, 04:58 PM
Ok well that`s a good start:) first problem solved.

Can you now try doing the same for the hidden files the Updater uses (the once u tried deleting before)

Shmevil
09-02-2012, 05:08 PM
no luck. Ran this updater, and well crash. Undid the read only on each folder and the file was already un-read only. any other ideas?

Konstantin Fomenko
09-02-2012, 05:13 PM
Starting to run out of ideas... last two things I manage to dig up - is uninstalling .net, restarting, installing it again, restarting, trying the installer.

And finally installing C runtime libraries. http://www.microsoft.com/en-us/download/details.aspx?id=5555

Shmevil
09-02-2012, 06:05 PM
sadly, did exactly that. even reinstalled the game again. nothin'.

Konstantin Fomenko
09-02-2012, 06:32 PM
Sorry we ran out of ideas, there is a chance our updater programmer to figure something out next week, but I`ll be honest chances are slim.

Shmevil
09-02-2012, 06:45 PM
Could it be something hardware? I got it to run on my desktop... I can't get it to run on my laptop. (My laptop is much better than my desktop so i'd prefer if I could use it)

Konstantin Fomenko
09-02-2012, 07:08 PM
No hardware is impossible. Well - the two causes of this crash
-there is no permission to create files for the updater
-updater can`t send cd key verification request over internet
and we made sure both of these are ok, so I`m afraid I`m stuck without ideas. I`ll be sure to run this by the updater programmer next week, maybe he can think of something.

Shmevil
09-04-2012, 06:47 PM
Well been trying everything you said... A bunch of times, found out my desktop can't even handle the game so sadly disappointed about that. Please send me a PM or post here when you run by your programmer. It'd be really nice to be able to play this game... seems like a fresh breath of air. Hopefully you guys can get this to work, if not maybe a team view... or worse gently let me know that I can't play the game. Anyways, thanks for all your help. Really appreciate it. Better then most support.

Shmevil
09-06-2012, 03:28 PM
Don't know if this is any help but, I went back and took a look. When I select the folder and uncheck the read-only box and hit apply. It applies to everything inside, but... When I go into the properties again the box is shaded again. Any idea if this is a problem? I also disabled UAC for now to see if it'll help.

Konstantin Fomenko
09-06-2012, 03:48 PM
Not sure, but it might be, I checked it on my computer and it`s not doing it.

Our utilities programmer is still away, but I`ll be sure to run your log by him as soon as he`s available. Sorry this is taking so long:(

Shmevil
09-06-2012, 03:50 PM
read up on what it means, it means it is "partially" read only...

Shmevil
09-12-2012, 03:07 PM
Sorry to be so persistent, Just wondering if there is any news that could help me?

Shmevil
09-17-2012, 04:43 PM
Hi, just wanting to know seeing as there was no reply to the last one... is there any bit of news that could shine some light on this issue?

Konstantin Fomenko
09-19-2012, 09:48 AM
Shmevil,

Sorry to say our program is also out of ideas. Please contact me at support@reverieworld.com if you would like a refund - since this is legitimate refund reason:(

The only lead I have - is that reinstalling the windows should help (well most likely) - as this is definitely not a hardware or software problem - something in Windows configuration just stops it from working - as far as we can say from the log.

Horlf
10-02-2012, 08:43 AM
Hi,
I've got the same problem here, did all that is mentionned above. The Read Only box is shaded each time. I uncheck it, apply, start the launcher, it crashes and Read Only is shaded again.
I tried to change the parameter, using cmd attrib -r C:\Program Files(x86)\Reverie World Studios. But it can't find program files (x86), even with quotes or if I type %programfiles(x86)%.
I tried in safe mode, same

mixvio
10-13-2012, 09:39 AM
I bought the game through the Green Light bundle, downloaded it and got the exact same issue; asked for the cd-key every time, then the game crashes with the same DOFupdater.exe error. Windows 8 x64 bit.

I have to say, coming here and finding a reply of "oops we don't know, guess you're out of luck" is truly baffling and concerns me greatly as a new customer. Offering a refund is one thing, but given that I found out about this game in the first place through a promotion to get it on Steam it doesn't exactly bode well for me.

Very hopeful you guys can come up with an actual solution instead of expecting people to shrug.

mixvio
10-13-2012, 09:47 AM
Running it through Visual Studio 2012 the debug error I get is

"TargetInvocationException was unhandled
Exception has been thrown by the target of an invocation."

and

"An unhandled Microsoft.NET Framework exception occurred in DoFUpdater.exe [1096]."

Konstantin Fomenko
10-13-2012, 04:49 PM
Hey Mixvio, Welcome to DoF - and sorry to hear it`s starting out so bad for you!

Please follow the steps here to resolve this issue: http://www.reverieworld.com/forums/showpost.php?p=73414&postcount=2

And just course the solution didn`t work for Shmevil, doesn`t mean it won`t work for you.