PDA

View Full Version : Lost units


Malicious
12-23-2011, 07:10 AM
I keep trying to give this game a chance, but over the past few days my brand new elven city, still too small to get attacked, keeps losing units. They dont get killed, they just disappear. I have lost the quest earned ENT, a set of rangers, and now the Christmas Ice dragon. I log off, log back on, and units are missing. What gives?

ingame Unser name is Malicious
city is in slot 2
lost the ent and rangers yesterday returning from the market on first market quest
lost ice dragon today immediately after a crash and logging back in

Revenger571
12-24-2011, 09:07 AM
The same thing is happening to me I am humans of southmont and i got dc and when I logged back in i lost my ice dragon and my 6 dwarven riflemen and the rest of my army that were in a army outside the town

Wolvman
12-29-2011, 02:30 PM
I've also lost units like this and I'm playing the Orcs. The last one I've lost was a level 9 ogre and two level 5 berserkers which disappeared immediately after I left a large NPC city.

I've also had my units temporarily duplicate whenever I form an army and then garrison them inside my town. It's even duplicated my hero twice so far, but whenever I log off and log back on it removes any duplicates. However I can still use them once they have been duplicated until I decide to log off.

Edit: Just lost 4 more ogres and two Wolfbeast Riders to this bug. Really starting to get annoying.

Neinth
12-29-2011, 05:39 PM
Just started an orc today myself,lost that first ogre on relog.