View Full Version : Ghost Armies, Dragons bugged

11-07-2011, 12:57 PM
I lost two armies. At least it seems so. Last time i was logged in, i created two armies (nos. 4 and 5). I logged in yust now to find 3 armies indicated in the left upper corner. Also only 3 armies are visible at the world map. So I tried to create army no 4 again. Unfortunately i am told that i already have 5 armies and i cannot create more armies.
As a result, I have now 3 armies visible and indicated and 2 ghost armies which I cannot see, move, disband or whatever.

Furthermore, I realised that my royal dragon requires now 32400 experience to reach level 6. Iwent hunting with my dragon to test abilities of the dragon and got experiance to reach level 2 (5 exp.), level 3 (10 exp.), ......, level 5 (20 exp.). At this time the statistics of the dragon indicated that i need 25 exp. to reach level 6. Back in town for healing of the dragon I saw that the exp. to reach level 6 changed to 32400.
The same happend to my green dragon. He is level 3 now and requires 540 exp. to reach level 4.

I hope you can resolve the bug and fix my dragons. I already lost a royal dragon (garrison in my elven town Fatschenbrunn) due to a bug (already reported in the forum but unfortunately no reply until now) and I dont want to have another two dragons spoiled by another bug.

Please resolve the above described bugs and help me if you can with ghost armies and bugged dragons.

For information:
Ingame name: wasserali
Town: Gornak, Slot 1
Race: Orks

Please tell me if further information is required.


Yust tried to resolve it my way:
Walked into battle with my royal dragon (map exploration) and let him be killed. Dragons resurerect in home town since patch 1.1.0 as we are told. I hoped that he will be reset to normal condition with rwgard to experience bug as explained above. Result is now I have a dead royal dragon lying in my home town. Looks realy silly. Update: 2 hours later dragon is alive! but experience bug still an issue!

My dragon count as follows:
1 royal dragon lost due to a bug (elven town Fatschenbrunn, slot 2)
1 royal dragon bugged (orc town Gornak, slot 1)
1 green dragon bugged (orc town Gornak, slot 1)

I did not get reply on my postings until now.
274 influence points spoiled.
This really sucks!!!

Further problems:
log in to my orc hometown requires 2 tries at least.First login is always no success. Second login is successful in 50% o tries.
Loss of hitpoints of armies if I garrison them in my hometown (Bug is described elswhere in the forum already).
Returning from any battle to word map takes very long or does not function. Therefore, I have to restart game almost after each battle.
Hero lost levels in two home towns (were 30, reduced to 15) .

I can continue for smaller bugs... but I dont want anymore!

At the moment playing this game is frustration only.


Next chapter: Groundhog day!

Another major bug to report: My orc town Gronak, slot 1 got stuck. Each time i enter the town first time after start of game it again starts at the time when I finally found out that my royal dragon has resurerected, but not healed. I heal the dragon in next town or let him heal at the small lake, etc. .... leave the game and restart ...... back to where my dragon entered the hometown for healing. Happy Groundhog Day!


Joseph Visscher
11-08-2011, 04:57 PM
I'll try to look at ur towns in the morning and figure out why there bugged. hopefully pull out a few errors out of them to fix :) hang in there.

11-09-2011, 04:20 PM
I also had an issue with one of my Dragons today. I had a Royal sitting in my booster bank, and after finally getting stone walls up on a 2nd city (Annuminas) I deployed it there. I had the population cap and everything, but the dragon just disappeared without a trace. Never spawned on my land, but from the World Map view I could see it listed in my Hometown troops. However, after logging off, it was gone forever.

I'd like the influence or dragon back, any help is appreciated :) I still have my Red and Haunted on my 1st city, and haven't had an issue, perhaps it's contained to Royals only.

11-16-2011, 11:53 PM
I tried to develop a new town (Hightower, slot 3). I succeeded very well until cloning happend several times. I dissmissed many armies to find out that the same happend to my new town as described for my town gronak, slo1t1, in the initial post. I can create only two armies. Creating the 3rd is not possible because my kindom can only support 5 armies, so I am told.

Also the experience bug with my haunter dagon happend again.

I tried to resolve all of this by dismissing all remaining units exceot my hero and my royal dragon.
Still no success in creating army no. 3.

In addition, my hometown tells me that 2 units are in town even it is empty.

It is again very frustrating to find out that the same bugs happen again and again. Especially this major bugs which spoil a town and vey expensive dragons. Gladly my royal dragon in this town is not spoiled until now. But to be honest, I expect that he will be spoiled as soon as I go into first battle wit him.

Please help!
I dont want to loose faith in this game because everything I started until now is spoiled.