PDA

View Full Version : Troop duplication, Training Troops Failure and Vanishing Gold


Pepi18
10-06-2011, 02:33 AM
After playing a day of Dawn Of Fantasy with the Elves today I hit 3 major bugs:

1. Troop duplication. On 4 separate occurances my main army with my hero had its troops duplicated until there were exactly 61/60 units in the army. Each time it happened after logging out and logging back in.

2. Training Troops at NPC towns failing. I brought my units to an AI town put them all in the training queue and pressed ok. Each time you press ok it levels up another level so I hit around 3 times and then it said I don't have any trainable units left. Knowing someone else trained all his units to lvl 5 I went to another, bigger, NPC town and tried there. The same thing happened - it said I didn't have any trainable units even though some of them were lvl 1. So I relogged. (Apart from my army being duplicated when I logged back in,) now I could train some of my units again but after a few clicks the same thing happened.

3. Vanishing gold. It first happened when I woke up this morning after having put all my gold on to my garrisoned army the night before. When I logged in 5k gold had vanished and turned into 7 gold. Then later this evening after accumulating over 200k gold during the day on one army, 50k gold on another (which were decaying at -54 /min), I relogged and both stacks vanished. 200k turned to 4.2k and 50k turned into 4.4k.

I consider these as gameplay interrupting bugs among which there are many in the game. I would like to see this game functioning properly more then I want to see new content released. I'm not going to play the game until the gold vanishing bug is fixed as it is becoming a headache for me.

Cheers.

PeekaBOOM
01-22-2014, 03:59 AM
On several occasions my army would duplicate aswell.

Upon making an army in the world map, some transferred units had a few soldiers still in my home town (one unit, low health) Those could be restored to full health and would essentially be a new unit group. Basically everytime i return my army after a quest to my town i end up with double the amount of units i start out with.

This all happened before the 12h noobie protection started ticking down, have not tried afterwards since the quest ''The trail continues'' is bugging out.

Wilffio
01-22-2014, 04:58 AM
This bug has been here for some time ... but don't worry the devs is working hard to fix it :)

/Wolf

Konstantin Fomenko
01-22-2014, 08:12 AM
Thanks for your report. Could you please tell us your in-game username, and town name (and describe the army) where these bugs happen? We`ll try to fix some of this for the up-coming patch.