PDA

View Full Version : Key doesn't work


Eightball
10-02-2011, 10:26 PM
Hi all,

I purchased Dawn of Fantasy via paypal. Luckily, I managed to take a note of my "Order Number" from the open webpage after purchase, because it does not appear in EITHER of the 2 e-mails I received after the purchase. In the e-mails I received an INVOICE number and a REFERENCE number.

None of these work when I try to activate my account.

It specifies it wants an Order Number, so I tried that first, it says "No Order Found".

Tried the others, it will say Invalid Key or whatever. So it appears the Order Number I got was a key, it just doesn't work =(

Can anyone help please? I have e-mailed about the problem, but without a live chat service, I am really not confident in receiving help in any kind of timely manner.

Eightball
10-02-2011, 10:29 PM
Nevermind, I figured it out. It wanted the same e-mail I used to do the purchase with. Which might I add, is not my own e-mail, I paid the person in cash and they used their paypal. How ******ed is this that I am forced to use their e-mail now for the game? Doesn't this company understand the principle of a gift? WTF?