PDA

View Full Version : Editor not Working? Here`s a fix.


Konstantin Fomenko
09-28-2011, 08:47 PM
Hey Guys,

If you experience issues with starting Editor - a start-up crash or some error message - this is due to Editor software requiring .Net Framework to run.

You can download it from the Microsoft website here: msdn.microsoft.com/en-us/netframework/aa569263

Have fun with the editor!

Kahotep
09-30-2011, 08:44 PM
Ever since installing the .NET thing, I no longer get the error message---instead nothing happens! What is going on?

Konstantin Fomenko
10-01-2011, 02:28 PM
Lets diagnose this for you.

After you try running editor and nothing happens, please post Log1.txt file in your reply here. You can find it in the main Dawn of Fantasy installation folder.

Kahotep
10-01-2011, 03:59 PM
Problem is that my log1.txt has too many characters in it to post here.

Konstantin Fomenko
10-01-2011, 04:02 PM
Try to Zip or Rar the file, and use forum`s Attachment Manager (you can see it when posting a reply). And just upload that Zip or Rar of the log here.

Kahotep
10-01-2011, 04:19 PM
Try to Zip or Rar the file, and use forum`s Attachment Manager (you can see it when posting a reply). And just upload that Zip or Rar of the log here.

I can't attach any files to this forum. :confused: In fact the posting rules at the bottom say I can't.

Joseph Visscher
10-01-2011, 05:11 PM
I've had major problems getting the editor to work after a complete reformat. my suggestion is to install every .net framework, 1.1, 2, 3, 3.5, and then 4.
if it still is not working.

try installing Microsoft Visual C++ 2008 Redistributable
http://search.microsoft.com/results.aspx?q=2008+C%2b%2b+Redistributable&form=&mkt=en-us

Those should get it going.

Kahotep
10-01-2011, 07:10 PM
OK, got it to work. Thanks!

Dreamwalker
11-03-2011, 05:14 PM
Hey, I have a problem too: like Kahotep, my editor won't start, but has an error message: "Editor.exe has encountered a problem and needs to close". I have the .net framework 4 installed, and I still get the same error message (while Kahotep just had nothing). What should I do? The same thing as Kahotep? Or is there way other than to install every .net framework there is? :(

Grizzlez
12-04-2011, 07:02 AM
I have the latest version .net framework, when I click the editor button nothing happens except it changes the cursor to loading for a few seconds then just goes back to the way it was. This is the same as, before I got .net framework.

Grizzlez
12-19-2011, 05:25 PM
Run as admin got it to work in case anyone else had problems.

Deacon
03-09-2012, 05:54 PM
I am having a similar issue, I have gone through and done all of the things that this thread has recommended (except for running in admin, because I don't know how to do that), but the editor is still not opening and the cursor is changing to busy for a short while and changing back.

Konstantin Fomenko
03-12-2012, 03:12 PM
If you have installed Microsoft .Net framework and Microsoft Visual C++ 2008 Redistributable the only other thing to try is to run Editor.exe directly from the main Dawn of Fantasy folder and not from the Updater.

ALSO - there is a good chance it`s your anti-virus software blocking the Editor.exe, temporary disabling your anti-virus, or adding Editor.exe to anti-virus safe programs list might help.